Question: Not able to get Email Alerts when using an Email Enabled Windows Security Group in SharePoint 2007


I have a situation where I have an email enabled security group with individual users in it, this security group is added to a SharePoint group. Here are some known

  • I am using the Site Owner to Add Alerts on behalf of users
  • if you enter the email address a user into the "Send Alert To" field and click ‘check name’, it resolves to the User
  • if you enter the email address of the Security group into the "Send Alert To" field and click ‘check name’, it come back "No Matches Found", same if you go to the Browse Icon
  • If you try to create the alert anyway using the security group, it creates the alert but tells you that there is no email address associated with the security group
  • If  you just add the preferred name of the Security Group to the "Send Alerts To" field then it resolves; but it creates the alert but tells you that there is no email address associated with the security group

However

  1. I created a new Email Enabled Security Group and two Test users today
    1. Test user 2 is a member of the Email Security Group
    2. I am able to send emails to test user 1, test user 2, and the security group in Outlook
  2. I did a full import into SharePoint and they all show up WITH their associated Email Address in the Profile
  3. I added the Security Group [Add User] directly into the Site as a contributor
    1. Tried to setup an alert. you get what is in top bullet 3 and 4
  4. I added the Security Group to a SharePoint Group, then added the SharePoint Group to the Alerts; failed…

I pulled down a feature from CodePlex http://www.codeplex.com/AdvancedAlert and tried list number 4 above; failed, but if i added an Individual User to the SharePoint Group and did number 4, the individual user gets alerts

I saw this out there also.. tired it… failed http://blog.gavin-adams.com/2007/10/26/sending-alerts-to-groups-in-sharepoint-2007/

Thoughts?

RESOLUTION

I found out that the Web Application Pool along with a few other accounts are Local Accounts

 

So the test/fix

· I created a new Web Application and used a domain account they had out there as the Web App Pool account

· I NOW am able to resolve the Security Group Email address

· I NOW can receive the initial alert email

· Once I added the Security Group to a Permission Group in SharePoint for the site (View, Read, Contribute) directly

    • I can receive security trimmed email alerts

Next we document and use the KB article 934838 to change the accounts in production

Tuck this one away people…

Leave a comment

Your email address will not be published. Required fields are marked *